Resolved: Latency Spikes on Oct 2, 2024
Incident Report for Ribbon Health
Resolved
Yesterday, between 10 AM and 5 PM ET, we experienced intermittent latency spikes affecting a portion of our customers. The issue has been resolved, and we are closely monitoring the situation to ensure continued stability. We apologize for any inconvenience this may have caused.
Posted Oct 03, 2024 - 12:17 EDT
This incident affected: Providers Endpoint (Provider Search, Editing Providers), Locations Endpoint (Locations Search, Editing Locations), Reference Endpoints (Specialties, Insurances, Clinical Areas, Conditions, Treatments), and Other (Eligibility Check (powered by pVerify), Procedure Cost Estimate).