Deductible Check (powered by Change Healthcare) - Intermittent Processing Issues
Incident Report for Ribbon Health
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 17:01 EDT
Monitoring
Please note this message does not affect customers who have migrated to our Eligibility Check endpoint powered by pVerify.

Our clearinghouse partner for our Deductible Check endpoint, Change Healthcare, is experiencing intermittent processing issues. We will monitor and share updates as this issue gets resolved.
Posted Apr 25, 2022 - 13:48 EDT