API Latency
Incident Report for Ribbon Health
Postmortem

The issue was caused by our API Redis instance running out of memory. As an immediate term fix we increased the size of the Redis instances in order to reduce latency. We have been monitoring the API the past few days and are seeing the service maintain the baseline performance we expect.

We are also profiling our API platform to better understand where the spikes in memory are coming from and addressing those at core to ensure that this sort of incident does not happen again.

Please don’t hesitate to reach out if you have any further questions or concerns in the meantime. We sincerely apologize for this incident and the impact it had on your team and your end-users.

Ribbon Team

Posted May 18, 2023 - 16:15 EDT

Resolved
This incident has been resolved.
Posted May 12, 2023 - 14:13 EDT
Update
We are continuing to investigate this issue.
Posted May 12, 2023 - 10:16 EDT
Investigating
We are currently investigating this issue.
Posted May 12, 2023 - 10:15 EDT
This incident affected: Providers Endpoint (Provider Search, Editing Providers), Locations Endpoint (Locations Search, Editing Locations), Reference Endpoints (Specialties, Insurances, Clinical Areas, Conditions, Treatments), and Other (Eligibility Check (powered by pVerify), Procedure Cost Estimate).